Solved: Problem running gnupg-0.9.0 from a daemon, a (minor) BUG?

Hartmut Wolf Hartmut.Wolf at KirchGruppe.DE
Thu Jan 7 12:15:16 CET 1999


First: Thanks to Brian who gave me all the hints needed to make it

What I had to do:

I needed to MODIFY cipher/random.c: uncomment the use of tty_printf
command in line 409. This caused a fatal error if gpg is run from a

gpg: fatal: cannot open /dev/tty: No such device or address

Is this a BUG or a fuse to keep people from using it if they don't
have a proper random device? It does not go away if I include
"load-extension rndunix" in the options file as suggested in the


PS: I'm using 0.9.0.

Hartmut Wolf <Hartmut.Wolf at> writes:

> Hi!
> Maybe this is not gnupg specific, but maybe someone can give me the
> idea: 
> I'm running gnupg like this 
> cat somefile | \
> 	gpg --batch -r $toaddress -q -a  -e | \
> 	mailx -s 'subject' $toaddress
> if I run from the command line it works fine (so everything should be
> setup correctly). If the daemon runs it, I get empty mails. To me
> (more user than admin) this looks like a "there is no controlling tty"
> problem, but I can't really tell.
> Anybody got an idea? 
> Thanks a lot
> Hartmut

More information about the Gnupg-devel mailing list