file size limit bug?

Lee McKenna lee at
Thu Sep 7 10:09:28 CEST 2000

Is there a file size limit that gpg can handle?

I've encrypted several large (greater than 3.5GB) files and when I try
to decrypt I get the following:

gpg: [don't know]: invalid packet (ctb=57) near 281685836
gpg: [don't know]: invalid packet (ctb=61) near 281685837

I'm running on FreeBSD-4.1-stable, with version GnuPG 1.0.2 as installed

from the FreeBSD ports collection.  I've tried the Windows version too
with similar results.  I've tried changing the key length to 768, I've
tried different ciphers like Blowfish, 3DES, etc.

Interesting to note that if I encrypt using a symmetric key by supplying

a simple passphrase, decrypt then works fine on these large files.

Is this a bug?

A 300MB file works fine, by the way...just chokes on the 3GB or
larger...have not tried anything in the 2GB range yet...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: lee.vcf
Type: text/x-vcard
Size: 450 bytes
Desc: Card for Lee McKenna
Url : /pipermail/attachments/20000907/d33697d0/lee.vcf

More information about the Gnupg-devel mailing list