file size limit bug?

Lee McKenna lee at
Mon Sep 11 09:10:53 CEST 2000

After reading some other posts about this, I have solved my problem by
piping the files into the gpg command, like this:

To encrypt:
cat 2388.mpg | gpg -e -o 2388.mpg.gpg -r lee at

To decrypt:
cat 2388.mpg.gpg | gpg -d -o 2388.mpg.decrypted

By the way, I successfully encrypted and decrypted large files 3GB, 4.5GB,
and 4.8GB on both versions 1.0.2 and 1.0.2b and both work fine, using it on
FreeBSD 4.1.

Thought others on the lists might find this info useful.


Lee McKenna wrote:

> Is there a file size limit that gpg can handle?
> I've encrypted several large (greater than 3.5GB) files and when I try
> to decrypt I get the following:
> gpg: [don't know]: invalid packet (ctb=57) near 281685836
> gpg: [don't know]: invalid packet (ctb=61) near 281685837
> I'm running on FreeBSD-4.1-stable, with version GnuPG 1.0.2 as installed
> from the FreeBSD ports collection.  I've tried the Windows version too
> with similar results.  I've tried changing the key length to 768, I've
> tried different ciphers like Blowfish, 3DES, etc.
> Interesting to note that if I encrypt using a symmetric key by supplying
> a simple passphrase, decrypt then works fine on these large files.
> Is this a bug?
> A 300MB file works fine, by the way...just chokes on the 3GB or
> larger...have not tried anything in the 2GB range yet...
> --Lee
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lee.vcf
Type: text/x-vcard
Size: 450 bytes
Desc: Card for Lee McKenna
Url : /pipermail/attachments/20000911/b4fae72d/lee.vcf

More information about the Gnupg-devel mailing list