symmetric encryption broken

Michael H. Warfield mhw at
Fri Mar 9 21:23:07 CET 2001

On Fri, Mar 09, 2001 at 11:41:25AM -0700, Nathan Johnson wrote:
> For tests on my system, under no circumstance does symmetric encryption

> (gpg -c)

> work.  Files become scrambled, but never de-scrambled.  Files aren't even the
> same size after reversing the encryption.  I have tried various encryption and
> compression algorithms.

	What happens if you specify "a" (ascii armor) or "t" (text file)?

> Is generic symmetric encryption of files un-implemented?  a known problem?
> If there is more information or tests I can provide, please let me know.

	Seems to be working fine on my system and I decrypt symetrical
stuff all the time.  I would be in serious hurt if that didn't work.

> Here is information on my system:

> gpg (GnuPG) 1.0.4
> Supported algorithms:

	Have you tried different algorithms to see if that makes a
difference.  I'm largely stuck working with Idea, due to compatibility
issues with PGP 2.6.2.

> libc 2.2.1

	Hmmm...  RedHat 7.0?

> Linux 2.4.2
> AMD Duron

	I'm running RedHat 6.x on several machines (libc 2.1.3) with 2.4.2
and not experiencing any problems with that.

> /usr/bin/gpg: ELF 32-bit LSB executable, Intel 80386, version 1, dynamically
> linked (uses shared libs), stripped

 Michael H. Warfield    |  (770) 985-6132   |  mhw at
  (The Mad Wizard)      |  (678) 463-0932   |
  NIC whois:  MHW9      |  An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!

More information about the Gnupg-devel mailing list