Installation problems...

Strawn, Eric R. Eric.Strawn at
Thu Jun 13 23:56:02 CEST 2002

Max, thanks for your response.  Your English is just fine.

As for Gnumake, I again am having problems.  I was able to download, unzip
and untar the file.  I then ran:

CC=gcc CFLAGS=O2 ./configure --prefix=/usr/local/gmake

The configure seemed to work fine, no fatal errors.  I then tried to run
make and got the following error:

 make  all-recursive
Making all in glob
        /usr/local/pa20_64/bin/gcc -DHAVE_CONFIG_H -I. -I. -I..
  -O2 -c glob.c
<command line>: warning: "__STDC_EXT__" redefined
<command line>: warning: this is the location of the previous definition
In file included from
                 from glob.c:33:
/usr/include/sys/_fd_macros.h:91: parse error before "int"
*** Error exit code 1

*** Error exit code 1

*** Error exit code 1


I also tried the script but get the following error:

compiling ar.c...
<command line>: warning: "__STDC_EXT__" redefined
<command line>: warning: this is the location of the previous definition
In file included from
                 from gettext.h:35,
                 from make.h:43,
                 from ar.c:20:
/usr/include/sys/_fd_macros.h:91: parse error before "int"
In file included from ar.c:20:
make.h:252: conflicting types for `bcopy'
/usr/include/strings.h:52: previous declaration of `bcopy'

I just can't seem to get this make process to work for everything.  All I
want to do is get the GnuPG software installed.  Does anyone know if it's
possible just to download the binaries for GnuPG rather than the source
(meaning I have to compile, configure, etc, etc)?  I'm at a loss with this
make process since I have no experience with it.

Any information would be greatly appreciated.  Thanks again...

-----Original Message-----
From: Max V. Zinal [mailto:Zlat0 at]
Sent: Thursday, June 13, 2002 2:53 PM
To: Eric R. Strawn
Cc: GnuPG developers mailing list
Subject: Re: Installation problems...

Strawn, Eric R. wrote:
> I was able to run the configure by executing the following command:
> CC=path CFLAGS='-O2 -pipe' ./configure
> where the path value is the location of your compiler (in my case, the gcc
> compiler).  When I ran this (again, on HPUX-11i) it ended without any
> errors.  I then went and ran 'make' but came across the syntax error shown
> below:
> Making all in keyserver
> Making all in po
> Making all in doc
> Make: line 180: syntax error.  Stop.
> *** Error exit code 1

It seems to me that you are using HP `make'. Not an excellent choice for 
building GNU-style software, I think. I do not know whether there is 
such a recommendation in GnuPG docs, but I highly recommend you to 
install the latest GNU `make'. This is a very simple and straightforward 
procedure, even if you will have to build it from sources. This can save 
you a lot of time. All the makefiles you are dealing with were generated 
automatically by configure, which was utself created by autoconf. Those 
guys who have made that stuff expected GNU `make'. There ARE 
incompatibilities betweeen different `make's.

Again, I recommend you to alter you PATH so that configure, makefiles 
and I don't know who else could find `gcc' and GNU `make'. This simple 
decision will save your time.

> When I checked in the /doc subdirectory at the Makefile and
> objects at that particular line (180), I found:
> : gpg.texi
> gpg.dvi: gpg.texi
> gpgv.texi
> gpgv.dvi: gpgv.texi
> I changed the first line to be commented (#) though I'm not sure that is
> correct.  Should it be the following?:

Modifying an automatically-generated file is not a good idea. I am not a 
`make' guru, although I use GNU `make' intensively. I suppose that this 
construct is quite OK for GNU `make', but your `make' from HP - or 
should I call them HPQ now ;) - doesn't like it.

> Does anyone know if these are related?  Or absolutely unrelated?  I did
> check on the library and it does NOT exist.  The only related objects in
> /usr/lib/nls/loc/pa20_64/locales.2/ directory that I see are C.iso88591,
> C.iso885915 and C.utf8 which are all executables.

The latter error doesn't make much sence for me. But what I would have 
done in such situation:

    1. Install the latest version of GNU `make', either in the binary 
form or build it from sources. An executable can be called `gmake' or 
    2. Alter PATH in your Bourn shell:
         PATH=/path/to/GNUmake:/path/to/gcc:$PATH; export PATH
    3. Once again, unpack GnuPG distribution:
         gzip -dc gpc-1.0.7.tar.gz | tar xvfi -
    4. Run configure as follows:
         CC=gcc CFLAGS='-O2 -pipe' ./configure --prefix=/usr/local/gpg
    5. If configuration fails, then you or me have made a mistake 
somewhere. Otherwise, invoke GNU `make':

I cannot test all these, because currently I do not have access to 
HP-UX. But this _should_ work, although there may be some problems 
during compilation. Good luck.

Best regards,
   Max V. Zinal
   Zlat0 at

P.S. Sorry for my English.

More information about the Gnupg-devel mailing list