[Fwd: Re: Compiling GnuPG on Cygwin]

Max Zinal Zlat0 at mail.ru
Fri Dec 5 21:30:56 CET 2003

> How do I build the GnuPG 1.2.3 binary from the source so that the binary
> doesn't need any cygwin DLLs to run? I've tried to use --with-static-all
> in the ./configure step, but GnuPG still needs three cygwin DLLs to
> work. If they're not located in the same folder as gpg.exe (or perhaps
> in my system path), GnuPG won't run. Also, when I put the binary in the
> C:\GnuPG directory (where the MinGW32 binary goes) and use it, it
> doesn't use the keyrings or gpg.conf in that directory, but instead
> creates a new keyring pair in C:\cygwin\home\My Computer Name\.gnupg
> which Gygwin considers as my "Home" directory.

AFAIK it is not possible to create a Cygwin binary which does not
rely on at least cygwinXXX.dll.

> When GnuPG is run from the command line, it reports Home: ~.gnupg
> What can I do so that the binary uses the C:\gnupg directory as its home
> directory, or whatever directory I specify in the registry? I've tried
> putting SET GNUPGHOME=C:\GnuPG in autoexec.bat, and this does make GnuPG
> use C:\GnuPG keyrings and gpg.conf, but then every time I run it, it
> gives me a warning about my home directory having unsafe file
> permissions. What can I do when building GnuPG so that it will use the
> registry entries to decide on its home directory, and so that it will
> quit giving me that "unsafe file permissions" warning. I'm not sure what
> purpose this has on windows.

   chmod 700 /cygdrive/c/gnupg
from Cygwin's bash prompt.

More information about the Gnupg-devel mailing list