Encrypt/decript large files

David Shaw dshaw at jabberwocky.com
Mon Jun 23 02:55:03 CEST 2003

Hash: SHA1

On Thu, Jun 19, 2003 at 05:54:02PM -0700, Eric Harlow wrote:
> Encrypting small files is no problem.  However, when I
> try to encrypt/decrypt a large database backup on
> Win2k, it appears to encrypt fine - but it's hard to
> tell since when I try to decrypt the file, I get an
> error.  The original file is slightly over 6 gigabytes
> and will probably grow in time.  I've tried this
> several different ways - symmetric keys, with and
> without the --armor option and they all seem to give
> me basically the same error.
> C:\gpg>gpg --decrypt test2.asc > decrypt.avi
> You need a passphrase to unlock the secret key for
> user: "NASD EFP test (Testing gpg) <harlowe at nasd.com>"
> 1024-bit ELG-E key, ID BA9F0893, created 2003-06-19
> (main key ID F8C0FC92)
> gpg: encrypted with 1024-bit ELG-E key, ID BA9F0893,
> created 2003-06-19
>       "Company test (Testing gpg) <fakename at co.com"
> gpg: [don't know]: invalid packet (ctb=1f)
> gpg: [don't know]: invalid packet (ctb=0f)
> gpg: WARNING: encrypted message has been manipulated!
> gpg: fatal: zlib inflate problem: invalid block type
> secmem usage: 1408/3328 bytes in 2/9 blocks of pool
> 4256/32768

Can you tell me what version of GnuPG you are testing with?  Also,
how did you encode the file (that is, "gpg --encrypt (thefile)" or by
piping the data to "gpg --encrypt" on stdin).

Version: GnuPG v1.2.3rc1 (GNU/Linux)
Comment: Key available at http://www.jabberwocky.com/david/keys.asc


More information about the Gnupg-devel mailing list