Albrecht Dreß albrecht.dress at
Tue Apr 27 20:50:52 CEST 2004

Am 27.04.04 10:59 schrieb(en) Werner Koch:
> Definitely not.  However I am of course using the CVS version and only
> realized last week that there was no release since December.  Thus I
> released 0.7.1 last week - did you already tried it?

Installed 0.7.1, still the same problem... And there *is* a problem with  
national characters. Running pinentry-gtk directly from the command line,  
and then saying

setdesc us-ascii text

displays "us-ascii text", whereas

setdesc Test with äöüÄÖÜß

displays an empty line (i.e. not even "Test with "). An other strange  
thing is that it emits

pinentry-gtk: no LC_CTYPE known - assuming UTF-8

twice after giving getpin, even if I run it (in bash) using LC_ALL=de_DE  
pinentry-gtk. My environment *is* set up properly, btw, locale says that  
everything is "de_DE".

And, finally, when run by gpg-agent, the window doesn't come up with the  
preferred (programmed) theme, but with the default one - running it from  
the command line pops up the window in the correct theme.

Any ideas?

Thanks, Albrecht.

 Albrecht Dreß  -  Johanna-Kirchner-Straße 13  -  D-53123 Bonn (Germany)
       Phone (+49) 228 6199571  -  mailto:albrecht.dress at

More information about the Gnupg-devel mailing list