Compiling gnupg on HP-UX 11.11

Stucki, Dave Dave.Stucki at
Fri Jan 28 15:27:02 CET 2005

Hello all,

'configure' ran clean.
When I first did the 'make' on the source, I received the following
error message in the standard output, which caused the compile to fail:

: conversion from `utf-8' to `roman8' not available

So I changed my locale from the hp-ux standard "C" to "C.utf8" and attempted
again to "make clean" and "make" again.  This time with success.  Then I did
a "make install".  Logged in fresh and tried to create a new key pair and
the same error:

gpg: conversion from `utf-8' to `roman8' not available

Attempting to get the binary to run successfully, I again changed my locale
from "C" to "C.utf8".  Key pair was successfully generated.  Tried to use
the key pair to generate an encrypted hash of a plain text file and the
looked like a binary file, instead of a crypt hash.

I've looked high and low and even opened a call with HP to get help, all to
no avail.

Anyone who might have a clue about this problem?


Dave Stucki
Senior Systems Programmer/Analyst
HP Certified System Administrator
Summit Information Systems
dave dot stucki at summit dot fiserv dot com

More information about the Gnupg-devel mailing list