Compiling gnupg on HP-UX 11.11

David Shaw dshaw at
Fri Jan 28 17:25:36 CET 2005

On Fri, Jan 28, 2005 at 06:27:02AM -0800, Stucki, Dave wrote:
> Hello all,
> 'configure' ran clean.
> When I first did the 'make' on the source, I received the following
> error message in the standard output, which caused the compile to fail:
> : conversion from `utf-8' to `roman8' not available
> So I changed my locale from the hp-ux standard "C" to "C.utf8" and attempted
> again to "make clean" and "make" again.  This time with success.  Then I did
> a "make install".  Logged in fresh and tried to create a new key pair and
> received
> the same error:
> gpg: conversion from `utf-8' to `roman8' not available
> Attempting to get the binary to run successfully, I again changed my locale
> from "C" to "C.utf8".  Key pair was successfully generated.

It looks like you have two different, and unrelated problems here.
This one is just that you have a problem converting utf8 to whatever
character set you are using.  OpenPGP stores things like user IDs in
utf8.  The character set choosing algorithm will be better in 1.4.1,
but in the meantime setting the locale to C.utf8 is fine.

> Tried to use the key pair to generate an encrypted hash of a plain
> text file and the output looked like a binary file, instead of a
> crypt hash.

This is a different problem.  GnuPG outputs binary unless told
otherwise.  If you want ascii armor, you need to add --armor to your
command line.


More information about the Gnupg-devel mailing list