Out of memory error, Mac 10.6, GnuPG 1.4.10

Linus Karlsson dt08lk9 at student.lth.se
Fri Sep 4 15:57:08 CEST 2009


Today I downloaded and compiled GnuPG 1.4.10 to my Mac running Snow  
Leopard. The compilation went smoothly, with no errors (using ./ 
configure --disable-asm ).

I created a set of new keys, a main key, RSA 4096-bit, and two 2048- 
bit subkeys, which I moved to my OpenPGP-card.

I have tried to encrypt two different files with my encryption subkey,  
showing no error. But when I try to decrypt them gpg gives me this  

macbook:Desktop linus$ LANGUAGE=en_US gpg -d test.txt.gpg
gpg: anonymous recipient; trying secret key 01DB6623 ...
gpg(22464) malloc: *** mmap(size=140733193392128) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
gpg: out of  memory while allocating 27 bytes

(The same error is given without the LANGUAGE var, but with the first  
line of the output in Swedish).
The decryption error remains the same regardless if the OpenPGP card  
is inserted in the card reader or not.

However, if I encrypt the file with: gpg -e -a testfile.txt  (with  
ASCII-armoring), the decryption works without any problems.

Has anyone encountered the same error?


More information about the Gnupg-devel mailing list