Out of memory error, Mac 10.6, GnuPG 1.4.10

David Shaw dshaw at jabberwocky.com
Fri Sep 4 19:04:27 CEST 2009

On Sep 4, 2009, at 9:57 AM, Linus Karlsson wrote:

> Hi!
> Today I downloaded and compiled GnuPG 1.4.10 to my Mac running Snow  
> Leopard. The compilation went smoothly, with no errors (using ./ 
> configure --disable-asm ).

Does it pass 'make check' ?

> I created a set of new keys, a main key, RSA 4096-bit, and two 2048- 
> bit subkeys, which I moved to my OpenPGP-card.
> I have tried to encrypt two different files with my encryption  
> subkey, showing no error. But when I try to decrypt them gpg gives  
> me this error:
> macbook:Desktop linus$ LANGUAGE=en_US gpg -d test.txt.gpg
> gpg: anonymous recipient; trying secret key 01DB6623 ...
> gpg(22464) malloc: *** mmap(size=140733193392128) failed (error  
> code=12)
> *** error: can't allocate region
> *** set a breakpoint in malloc_error_break to debug
> gpg: out of  memory while allocating 27 bytes
> (The same error is given without the LANGUAGE var, but with the  
> first line of the output in Swedish).
> The decryption error remains the same regardless if the OpenPGP card  
> is inserted in the card reader or not.

Can you run a test without using the card at all?  That is, create the  
main 4096-bit key, and the two 2048-bit subkeys, and encrypt your test  
file in the same way (using --throw-keyid or --hidden-recipient it  
seems), but without transferring the key to the card first.

Something seems wonky in memory allocation (140733193392128 is  
7FFF00001000, which is more than a little suspicious).

If you happen to have a Mac that isn't running Snow Leopard handy, it  
would be great if you could try it there as well.


More information about the Gnupg-devel mailing list