gpg-agent: use --disable-scdaemon, yet still get SC-related error?

Werner Koch wk at
Mon Nov 28 10:31:48 CET 2011

On Sun, 27 Nov 2011 22:38, jim at said:

> Yet in spite of that --disable-scdaemon option, I still get what looks
> like an SC-related error in the log each time I try to use gpg:
> (and the agent fails to do its job):
>     2011-11-27 22:29:21 gpg-agent[13380] error getting default authentication
>       keyID of card: Not supported

Not a real error, should be reworded as "note".  Will do so for master.

The gpg-agent always tries to use a key from a smartcard for ssh
authentication.  Thus it asks scdaemon whether a suitable smartcard is
plugged in.  With scdaemon disabled or no suitabale smartcard, gpg-agent
tries the next key from the list kept in ~/.gnupg/sshcontrol :

"# List of allowed ssh keys.  Only keys present in this file are used\n"
"# in the SSH protocol.  The ssh-add tool may add new entries to this\n"
"# file to enable them; you may also add them manually.  Comment\n"
"# lines, like this one, as well as empty lines are ignored.  Lines do\n"
"# have a certain length limit but this is not serious limitation as\n"
"# the format of the entries is fixed and checked by gpg-agent. A\n"
"# non-comment line starts with optional white spaces, followed by the\n"
"# keygrip of the key given as 40 hex digits, optionally followed by a\n"
"# the caching TTL in seconds and another optional field for arbitrary\n"
"# flags.   Prepend the keygrip with an '!' mark to disable it.\n"



Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

More information about the Gnupg-devel mailing list