gpg-agent: use --disable-scdaemon, yet still get SC-related error?

Jim Meyering jim at
Mon Nov 28 11:06:40 CET 2011

Werner Koch wrote:

> On Sun, 27 Nov 2011 22:38, jim at said:
>> Yet in spite of that --disable-scdaemon option, I still get what looks
>> like an SC-related error in the log each time I try to use gpg:
>> (and the agent fails to do its job):
>>     2011-11-27 22:29:21 gpg-agent[13380] error getting default authentication
>>       keyID of card: Not supported
> Not a real error, should be reworded as "note".  Will do so for master.


However, with --disable-scdaemon why even bother to call card_key_available()?
Or, if calling it, why not return immediately when opt.disable_scdaemon is set?
Looking at the code, I would have been tempted to skip calling that function
altogether when !opt.disable_scdaemon.

  /* First check whether a key is currently available in the card
     reader - this should be allowed even without being listed in
     sshcontrol. */

  if (!opt.disable_scdaemon && !card_key_available (ctrl, &key_public, &cardsn))
      err = ssh_send_key_public (key_blobs, key_public, cardsn);
      gcry_sexp_release (key_public);
      key_public = NULL;
      xfree (cardsn);
      if (err)
        goto out;


Otherwise, that "note" seems confusing, since it appears to be talking
about SC-related support, which I've explicitly disabled.

More information about the Gnupg-devel mailing list