[solved] Re: Unable to compile GnuPG 2.1 beta 3

Alphazo alphazo at gmail.com
Wed Jan 11 22:48:55 CET 2012

Proposed patch fixes the problem. Thanks.

As a side note, thread is marked as solved but I still have to compile
gnupg2 with "--disable-dirmngr" ;)

I don't use X.509 certificates (yet) under GnuPG so I guess I can
leave without it.


On Wed, Jan 11, 2012 at 8:20 PM, Werner Koch <wk at gnupg.org> wrote:
> Hi,
> after some private mails, we finally found the bug:
> commit 30ec869b8c63f1edcc58110ed20b83b0e77248f8
>    gpg: Fix segv with RSA_S keys.
>    * g10/misc.c (pubkey_get_npkey, pubkey_get_nskey)
>    (pubkey_get_nsig, pubkey_get_nenc): Map all RSA algo ids to
>    --
>    The problem is that Libgcrypt has no more support for the alternate
>    RSA ids and thus if asking for the number of parameters, they will
>    return zero.  Now, this leads to packing the key parameters into an
>    opaque MPI but because the algorithm id is actually known to GPG, it
>    assumes valid RSA parameters.
>    An example key with RSA_S is 0x5434509D.
> Salam-Shalom,
>   Werner
> --
> Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

More information about the Gnupg-devel mailing list