pinentry-qt4 breaks Alt+Tab window switching in KDE

Maciej Sitarz macieksitarz at
Sat May 12 12:14:06 CEST 2012

W dniu 06.05.2012 19:11, Andre Heinecke pisze:
> On Thursday 03 May 2012 17:00:40 Werner Koch wrote:
>> Did anyone else tested this patch in the meantime?  Does it break
>> something?
> Just tried it.
> I could reproduce this problem with KDE 4.4.5 and Qt 4.6.3.
> But this Patch did not fix the Problem for me.
> After applying the patch I still get the "*** No Windows ***" Window.

Maybe it's because version differences between our systems? I've
upgraded my system, now I have qt 4.8.1 and kdebase-lib 4.8.3,
recompiled pinentry-qt4 and the fix still works.

> As far as I can tell, the patch just changes the call order bit and the 
> showEvent code should not be causing problems as long as this is not caused by 
> a qt bug (which I doubt). 

I just changed the call order to match with the confirm dialog call
order, as confirm dialog works properly.

> For me the problem looks much more related to grabbing. If I 
> use pinentry-qt without global grab (echo getpin | ./pinentry-qt4 -g) the 
> alt+tab works afterwards.

Using "-g" also works for me.

I did one more test, I've got Fedora 16 (qt-4.8.1-5.fc16.x86_64
kdelibs-4.8.3-1.fc16.x86_64 pinentry-qt-0.8.1-4.fc16.x86_64) and
pinentry works there. I checked the patches which Fedora devs use to
compile pinentry but nothing special[1].

I thought why try to run pinentry-qt4 from Fedora on Arch (both systems
up to date so there's no much lib differences).
I copied pinentry-qt4 and one missing library (, after
that I tried the test command[2]. After using it I got "*** No Windows
***" Window. So looks like the problem is not in pinentry-qt4 but in
some other libs (qt probably?).

[2] echo getpin | LD_LIBRARY_PATH=./ ./pinentry-qt4

Maciej Sitarz

More information about the Gnupg-devel mailing list