pinentry-qt4 breaks Alt+Tab window switching in KDE

Maciej Sitarz macieksitarz at
Sat May 12 13:15:17 CEST 2012

Please disregard my previous comment about pinentry-qt4 from Fedora not
working on Arch. It is working (forgot to add full path to binary, I ran
Arch's binary instead).

I decided to run some more tests... I tried to rule out the qt installed
on Arch. So I copied Qt libraries from Fedora to Arch and run few test
scenarios (all tests run on Arch):

Libs/Bins used                                   Result:
Qt(Arch) + pinentry-qt4(Arch)                    "No Windows" message
Qt(Arch) + pinentry-qt4(patched)                 OK
Qt(Arch) + pinentry-qt4(Fedora)                  OK
Qt(Fedora) + pinentry-qt4(Arch)                  "No Windows" message
Qt(Fedora) + pinentry-qt4(patched)               OK
Qt(Fedora) + pinentry-qt4(Fedora)                OK

Qt(Arch) - Arch system qt libs
Qt(Fedora) - binary qt libs taken from fedora
pinentry-qt4(Arch) - Arch system pinentry-qt4 bin
pinentry-qt4(Fedora) - binary qt libs taken from fedora
pinentry-qt4(patched) - pinentry-qt4 bin with my patch applied

All this makes me think pinentry-qt has a bug which is fixed in Fedora.
I checked Fedora's build and they apply only one patch[1].
I saw it before, but description didn't seem related to my issue. I gave
it a surprisingly it works!

Andre please give it a try and confirm.


Maciej Sitarz

More information about the Gnupg-devel mailing list