Decrypting with ECDH: no secret key

Daniele Ricci daniele.athome at
Sat Jun 29 12:26:18 CEST 2013

I was using the beta3 tarball. Shouldn't I?

Anyway just to be sure I just cloned gnupg from git and tried the same
tests. Same error :-(
Log is attached.
If you need more tests/data (e.g. a trace of some kind) just tell me.

On Wed, Jun 26, 2013 at 6:52 PM, Werner Koch <wk at> wrote:
> On Wed, 26 Jun 2013 18:07, daniele.athome at said:
>> However, if I try to export it, gpg2 outputs the key "correctly",
>> without the subkey, printing this warning:
>> gpg: key F08342D6/0AF4E702: error receiving key from agent: Bad secret
>> key - skipped
> Are you using the old beta tarball or a build from master?  If the
> latetr it would be good to see the log output from all tools:  Add
>   log-file socket:///foo/bar/S.log
>   debug 1024
>   verbose
> to gpg-agent.conf and gpg.conf.  Then run
>   watchgnupg --time-only --force /foo/bar/S.log | tee gnupg.log
> on another tty.
>> When re-importing the exported secret key in another keyring, the same
>> issue: hash mark after ssb.
> Yes, because the subkey is missing but the public key is available and
> has a corresponding private primary key.
>> gpg-agent was started in a custom environment (--homedir) and
>> GNUPGHOME set accordingly.
> An easy way to debug this is to use
>   GNUPGHOME=$(pwd) gpg-agent --daemon /bin/bash
> in a test directory und use this shell for all tests.
>> By the way: I don't know if it's normal, pinentry asked me the key
>> password twice during the export.
> Should not as long as the primart key and the subkeys alluse the same
> passphrase.
> Shalom-Salam,
>    Werner
> --
> Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: gnupg.log
Type: application/octet-stream
Size: 15728 bytes
Desc: not available
URL: </pipermail/attachments/20130629/06ce1ab0/attachment-0001.obj>

More information about the Gnupg-devel mailing list