Android gpg-agent crashes in libgcrypt when signing, decrypting, importing secret keys

Hans-Christoph Steiner hans at
Fri Jan 17 19:34:38 CET 2014

On GPG for Android, I've updated to the latest libgcrypt in master (or close
to it, its commit 4b7db51ad5d1bf98fd08ca3048f258059eca61a4).  Now it seems
that any operation that needs a passphrase is crashing somewhere in libgcrypt.
 I've tried building with auto-detection of CPU which enables Padlock, Intelt
DRNG, and NEON.  I also tried with --disable-padlock-support
--disable-drng-support --disable-neon-support, and seemed to get the same thing.

I've also tried running gpg-agent with and without --enable-ssh-support, and
same result each time.

Here's the basic backtrace:

#00  pc 00045fb4  /data/app-lib/info.guardianproject.gpg-1/
#01  pc 00043d98  /data/app-lib/info.guardianproject.gpg-1/
#02  pc 00043dc8  /data/app-lib/info.guardianproject.gpg-1/
#03  pc 00043f8c  /data/app-lib/info.guardianproject.gpg-1/
#04  pc 00019ac0  /data/app-lib/info.guardianproject.gpg-1/
#05  pc 00018294  /data/app-lib/info.guardianproject.gpg-1/
#06  pc 000184d0  /data/app-lib/info.guardianproject.gpg-1/
#07  pc 0000692c  /data/app-lib/info.guardianproject.gpg-1/
#08  pc 0001fac8  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#09  pc 0001ae24  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#10  pc 00017c4c  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#11  pc 0001b850  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#12  pc 0001d4b8  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#13  pc 00009d10  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#14  pc 0000632c  /data/app-lib/info.guardianproject.gpg-1/
#15  pc 000066e4  /data/app-lib/info.guardianproject.gpg-1/
#16  pc 00010b88  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#17  pc 00007a64  /data/data/info.guardianproject.gpg/app_opt/bin/gpg-agent
#18  pc 00001274  /data/app-lib/info.guardianproject.gpg-1/
#19  pc 0000d170  /system/lib/ (__thread_entry+72)
#20  pc 0000d308  /system/lib/ (pthread_create+240)

From the bug report in our tracker, you can download the complete build log, a
debug log from the Android app, a log from gpg-agent, and a log from gpgme:


PGP fingerprint: 5E61 C878 0F86 295C E17D  8677 9F0F E587 374B BE81

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 969 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20140117/6f84a912/attachment.sig>

More information about the Gnupg-devel mailing list