gpgme does not find engine on windows

Jeroen Ooms jeroen.ooms at
Wed Jul 15 22:22:42 CEST 2015

On Wed, Jul 15, 2015 at 7:59 PM, Andre Heinecke <aheinecke at> wrote:
> Did you initialize gpgme with gpgme_check_version [1] before this call?

Yes obliviously (otherwise it wouldn't have worked on other platforms i suppose)

> If you have a working gpgconf in your PATH environment variable you should not
> need to set anything for gpgme to work. Can you execute gpgconf from the
> command line on your system? (From another working directory)

Yes, gpg.exe gpg2.exe and gpgconf.exe are all available from the cmd shell.

> Of course, check out Kleopatra, GPA etc. and take a look at gpgme/tests
> especially gpgme-tool.c is a good example of how you can work with gpgme.

I tried several executables in gpgme/tests such as 'run-keylist.exe'
and each fails with the same error: <GPGME> Invalid crypto engine.

I am able to execute gpgme-tool.exe (which is in ./src, not ./tests),
however looking at the source it does call gpgme_engine_check_version?
I am not sure how to use gpgme-tool, what command can I run to test if
it actually found the engine?

More information about the Gnupg-devel mailing list