2.1.5; documentation build failure

Daiki Ueno ueno at gnu.org
Mon Jun 15 14:47:13 CEST 2015

Werner Koch <wk at gnupg.org> writes:

> On Mon, 15 Jun 2015 03:55, ueno at gnu.org said:
>> gnupg.texi:4: @include: could not find defs.inc
>> gnupg.texi:29: warning: undefined flag: VERSION
> defs.inc is build by these rules:
> which says that it should take the date from git if this is a git
> checkout or on a distributed tarball take it from a file tracking that
> date.  VERSION is read by mkdefsinc from config.h.

Yes, if I run "make defs.inc" in the doc directory, it works fine.
However, if I run "make all", it doesn't even build mkdefsinc nor

Apparently, there is no dependency from *.info to defs.inc.  I'm
attaching a log of 'cd doc && make'.  If you need more detailed output
(e.g make -d), let me know.  I'm using Automake 1.14.1.

>> I guess defs.inc should be properly marked as prerequisites, or the file
>> should be renamed back to version.texi?
> version.texi does not work with git because git does not preseve the
> modification time.  Thus the git log thing above.

If I replace defs.inc with version.texi in gnupg.texi, Automake emits
the following rules to Makefile.in:

  $(srcdir)/gnupg.info: gnupg.texi $(srcdir)/version.texi $(gnupg_TEXINFOS)
  gnupg.dvi: gnupg.texi $(srcdir)/version.texi $(gnupg_TEXINFOS)
  gnupg.pdf: gnupg.texi $(srcdir)/version.texi $(gnupg_TEXINFOS)
  gnupg.html: gnupg.texi $(srcdir)/version.texi $(gnupg_TEXINFOS)

So, I think, if you rename the file, you need to manually add
the dependencies, or maybe add defs.inc to BUILT_SOURCES, which should
be built before other rules (it works fine here).

Daiki Ueno
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: log.txt
URL: </pipermail/attachments/20150615/da7ba645/attachment.txt>

More information about the Gnupg-devel mailing list