begging for pyme name change

Vinay Sajip vinay_sajip at
Tue Oct 18 12:54:52 CEST 2016

Dear Daniel,

> A few of these are great concrete requests.  Have you tried asking for 
> them explicitly?  Opening a ticket at 

No, because I believe the reason for Windows being a second class citizen is "political" (if I can put it that way) rather than technical. I think Werner's just confirmed this in another post.

>> It's certainly possible for GnuPG upstream changes to make it harder
>> to use the wrapper approach (which is why I can't easily see a way to
>> support 2.1 properly in all respects, much as I'd like to).

> Can you explain this in more detail?  I'd really like to see
> python-gnupg support 2.1 better.  I might be able to offer you some
> patches, too :)

Example: I have a Ubuntu machine (16.04 LTS) with gpg 1.4.20 and gpg 2.1.11 installed.

If I run the tests for the python-gnupg project, using


I get no passphrase prompts and all the tests pass. If, however, I run

GPGBINARY=gpg2 python

I get not one, but two different passphrase prompts, as per these images:

There seems to be no way to get gpg2 to accept passphrases on fd 0 via a command-line argument. An example command line invoked from the test suite is

gpg2 --status-fd 2 --no-tty --homedir /home/vinay/projects/python-gnupg/keys --batch --passphrase-fd 0 --debug-quick-random --decrypt

On GPG earlier than 2.1, this causes no pinentry prompt to be shown. On 2.1, a prompt is shown. It may be possible to change this using some configuration changes in ~/.gnupg, but if GPG functionality is embedded in some other application (the use case for python-gnupg), we can't (a) change the user's configuration ourselves or (b) expect users to change their configuration, as they may not even be familiar with GnuPG themselves.

Quite apart from this, GPG2.1 changed the --with-fingerprint --with-colons listing format. Here's what a line looks like with 1.4:

pub:-:2048:1:CAD0AE184C7798F2:2014-07-27:::-:Andrew Able (A test user) < at>: 

and with 2.1:


The number of elements has gone down by one - it's not clear why, since according to the documentation in both 1.4 and 2.1 (the doc/DETAILS), the user id ("Andrew Able") is in the expected place in 1.4, but just not present in 2.1. I vaguely remember Werner suggesting that this was a bug in 1.4, but as the 1.4 behaviour conforms to the 1.4 documentation, it looks like a backwards-incompatible change to me. Note also how the expired date field format has changed from "2014-07-27" in 1.4 to "1406461871" in 2.1 (the value is the same, just presented differently).


Vinay Sajip

More information about the Gnupg-devel mailing list