gnupg-gdbm keyring hangs when importing keys

Roland Rosenfeld
Sat, 2 Oct 1999 12:28:04 +0200


My public keyring is growing and so I'm thinking about using the
feature to use a GDBM keyring with gpg.  The man page tells me:

       --keyring file
                 Add  file  to  the  list  of  keyrings.  If file
                 begins with a  tilde  and  a  slash,  these  are
                 replaced  by the HOME directory. If the filename
                 does not contain a slash, it is assumed to be in
                 the  home-directory  ("~/.gnupg" if --homedir is
                 not used).  The filename may be prefixed with  a

                 "gnupg-ring:" is the default one.

                 "gnupg-gdbm:" may be used for a GDBM ring.

                 It  might  make  sense  to  use it together with

So I exported the trustdb and ~/.gnupg/pubring.gpg away, and changed
the options file to mention only one public keyring:

keyring gnupg-gdbm:pubring.gpg

After this I tried to import the old key ring using gpg --import or
gpg --fast-import, but both commands hang (= consume CPU time, but
seem to do nothing) after importing one or two keys.  Starting it with 
-v doesn't help much:

$ gpg --import -v ../.gnupg.old/pubring.gpg
gpg: pub  1024D/BD8B050D 1999-06-05   Roland Rosenfeld <>
gpg: key BD8B050D: no subkey for key binding
gpg: key BD8B050D: public key imported
gpg: /home/roland/.gnupg/trustdb.gpg: trustdb created
[time passes until I press Ctrl-C]
gpg: Interrupt caught ... exiting

So I added --debug-all to the options, which gives me 3817 lines of
output.  Then the debug output stops but gpg still consumes CPU time.
The last lines of the debug output are:

gpg: DBG: parse_packet(iob=14): type=2 length=70 (parse.ringedit.c.1768)
gpg: DBG: mpi_alloc(160)
gpg: DBG: mpi_alloc_limb_space(160)
gpg: DBG: mpi_alloc(160)
gpg: DBG: mpi_alloc_limb_space(160)
gpg: DBG: iobuf-14.0: close `(null)'

I don't see what happens here.  Long time ago (when the gnupg-gdbm
feature was freshly implemented) I also tried this and it worked.  But 
because of the fact, that it wasn't able to remove keys from a gdbm
ring, I stopped using it in the past.  Is this feature no longer
available or am I missing something?

Is there someone else who uses gnupg-gdbm and is this usable?



 * * *
 PGP: 1024/DD08DD6D   2D E7 CC DE D5 8D 78 BE  3C A0 A4 F1 4B 09 CE AF