problem loading rsa extension to use with 2.6.3i key

Simon Amor
Tue, 4 Jul 2000 12:31:48 +0100


 I've been trying to use an imported key from pgp 2.6.3i but gpg never
seems to load the rsa module.

I have in the /home/admin/.gnupg/options file the following line:
load-extension /home/admin/.gnupg/rsa

I've tried using the default RedHat RPM as well as compiling my own but
no luck.

The rsa module was downloaded as rsa.c and compiled using the info at
the top of the file. The resulting file 'rsa' was placed in
I've also tried copying it to /usr/lib/gnupg/rsa

According to the mini-howto, RSA should show up in the Pubkey line.

[admin@sysadm1 admin]$ gpg --load-extension ~/.gnupg/rsa -h
gpg (GnuPG) 1.0.1
Copyright (C) 1999 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Home: ~/.gnupg
Supported algorithms:
Pubkey: ELG-E, DSA, ELG
Hash: MD5, SHA1, RIPEMD160

Syntax: gpg [options] [files]
sign, check, encrypt or decrypt
default operation depends on the input data

Doing an strace -o gpglog gpg --load-extension ~/.gnupg/rsa -h shows no
trace of 'rsa' in the logfile apart from the first line where it prints
the arguments.

I really need to be able to use gpg (because of the perl interface) with
a 2.6.3i key (not possible to change at the moment for various reasons).
Any suggestions as to why this isn't working would be welcomed.
Solutions are even more welcome ;-)