Win32 - export keys
Tue, 25 Jul 2000 16:54:21 -0300

Using gnupg win32, I could not create a valid exported key file using redirected
stdout.  I found that using the --output option, however, worked fine.

In other words:

gpg --export user1 > user1.key    (created a corrupted file)
gpg -o user1.key --export user1  (created a valid file)

I did further analysis on the corrupted files:

When I tried to import an unarmoured file, I'd get:
gpg: mpi too large (51968 bits)
gpg: mpi too large (41167 bits)

gpg: Ohhhh jeeee: mpi crosses packet bordersecmem usage: 0/0 bytes in 0/0 blocks
 of pool 0/16384

abnormal program termination

When I tried to import an armoured file I'd get this:
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

By examining the armoured exported keyfiles from both a stdout redirect and a
--output specified file, I found that the redirected file had an extra carriage
return at the end of line ( x'0D0D0A') where as the --output file had just
x'0D0A' end of lines.

Just thought you would like to know.  I tried searching the mailing lists and
Readme.W32 doc, but couldn't find anything a mention of this.

Thanks, Archie


When I tried to search the mail list archives... I got the following:

ht://Dig error
htsearch detected an error. Please report this to the webmaster of this site.
The error message is:

Unable to read word database file '/opt/db/db.words.db'
Did you run htmerge?