system hangs during key generation

David L Smith
Thu, 29 Jun 2000 14:22:36 -0500

I have only recently started using GNUpg myself, and have not tried what you
are doing.   However have you tried logging in a second connection to the
same machine and doing other work there while GNUpg is generating the key.
It is my understanding that GNUpg is waiting to gather random events from
other processes.
"J. Goodleaf" wrote:

> I've been trying out GNUpg, but am having one problem. When I connect
> through ssh, or telnet for that matter, I cannot generate a key. The app
> gets as far as key generation, then asks me to continue working so that it
> can gather more random data. I can whale away at the keyboard, and
> eventually, no further characters get entered onscreen. However, the
> system then hangs. If I work at the machine itself, the process is
> identical with the exception that, after whacking away at random keys, a
> key is actually generated. Any ideas? (The problem being that if I can't
> generate keys from a remote terminal, the system is useless to remote
> users. PGP 6.5.1 appears not to have this problem.)
> Am using FreeBSD 4.0-STABLE, with PII 266 and 64mb RAM; should be
> sufficient. Oh, and the network in question is a 10-base-T.
> TIA,
> John
> ===============================
> John Goodleaf
> PGP key: finger
> ===============================
-- David Smith = Linux is free. Life is good. = ********************************************************************* The man scarce lives who is not more credulous than he ought to be... The natural disposition is always to believe. It is acquired wisdom and experience only that teach incredulity, and they very seldom teach it enough. - Adam Smith