Collecting entropy?

Marius Strom
Thu, 30 Mar 2000 22:51:36 -0600 (CST)

BSD machine:
in /etc/defaults/rc.conf, set rand_irqs="<some irq's that are actually

It defaults to keyboard controller, IIRC, which is not helpful on a
headless terminal.

I use the IRQ of my disk controller, then run a find / creates wonderful
entropy. =]

Marius Strom <>
Professional Geek/Unix System Administrator
Alpha1 Internet <> 0x42C74CBA

In theory, there is no difference between theory and practice...
...In practice, there is a big difference.

On Fri, 31 Mar 2000, Darren Cook wrote:

> Hi,
> Each time I run gen-key, after answering all the questions it spends a few
> seconds putting dots and crosses on screen then says:
> Not enough random bytes available. Please do some other work to give
> the OS a chance to collect more entropy! (Need 20 more bytes)
> Then it seems to lock up. I've tried typing in that terminal, opening
> another one and running find and top, accessing the web server running on
> that machine, etc. But it still just sits there - no more dots or crosses.
> top is telling me it has used 0:02 seconds of processor time and is
> currently using 0% of the processor. I left it around 10 minutes and
> nothing happened, so I killed it and tried again. Again upto 10 minutes so
> far.
> top is also telling me another user has a perl script running at nice level
> 1 which is using up all free processor cycles (around 90%) - so that should
> be the work it needs shouldn't it?
> Has it crashed? Could it be caused by a missing file (I did ./configure,
> then make, but as I don't have root access, I installed by manually copying
> the gpg binary and then copied options.skel and edited it).
> Darren
> P.S. BSD machine. I tried it on Linux last night (same manual
> installation), and had a similar problem, but it woke up after about one
> minute and finished making the key.