Compiling on old Digital Unix

Brian Salter-Duke
Sun, 22 Oct 2000 10:49:51 +0930

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I have just compiled GnuPG for the first time on a Digital Unix using the
Digital cc compiler. It was the latest version - 1.0.4.

Some C compilers and the DU is one of them ignore lines such as "#ifdef
=2E." unless the # is in the 1st column (showing my Fortran upbringing - I
mean the 1st position on the line). This gives lots of errors. It was a
boring job to edit out all the spaces and tabs before #. Could the
developers please change this? It is a seriously bad thing to do. Not all
of us use gcc all the time.

When I run gpg, it tells me I do not have secure memory. OK I understand
this, but the message does not go away if I add "no-secmem-warning'. The
same happens with an old AIX 3.2.5 box. Here making gpg suid root also
does not make the warning go away. I have not tried that on DU. This
came up on the mutt list and I was told it was because I do not have
mlock. ./configure certainly says it has not found mlock. Is this
correct? Does mlock exist someway else on DU and AIX?

Regards, Brian.
Associate Professor Brian Salter-Duke (Brian Duke)
au =20
Chemistry, School of BECS, SITE, NT University, Darwin, NT 0909, Australia.
Phone 08-89466702.     Fax 08-89466847.
Get PGP2 Key:-

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: 2.6.3i



Archive is at - Unsubscribe by sending mail
with a subject of  "unsubscribe"  to