Make groups of keys in GnuPG?

Filip Stokkeland
Tue Feb 6 18:07:02 2001

Frank Tobin <> writes:

> I've created a genreric wrapper program called salias that can
> handle aliasing program arguments. In the most straightforward
> calling, it's easy to set it up to do something like:
> salias gpg -r friends --encrypt
> ...and have it run:
> gpg -r fred -r bob -r sam --encrypt
Hi! I have installed salias, and it seems to be working ok from the command prompt, but it does create some trouble for mailcrypt/gnus.
> or using the included salias-wrapper program.
I moved gpg and put this wrapper script in /usr/bin/gpg: #!/bin/sh base=`basename $0` salias --context $base /usr/bin/real/$base $@ But it got some problems: Problems encrypting: Encrypting+signing as filip <> ... Encrypting+signing as filip <> ... failed: gpg: \ Missing argument for option "--passphrase-fd" Problems decrypting: On one message I got this error: Loading mc-gpg...done Decrypting... [2 times] SIGPIPE raised on process *GPG*; closed it On another message I got this message: Decrypting... [2 times] The message was corrupt.
> You can transparently wrap salias by using shell aliasing:
> alias gpg="salias gpg"
I tried to remove the shell-script-wrapper and put the gpg back in its usual location (/usr/bin). An then I set the alias: alias gpg='salias gpg' But mailcrypt does not seem to recognize or use the alias at all: Encrypting+signing as filip <> ... Encrypting+signing as filip <> ... failed: gpg: \ skipped: public key not found gpg: [stdin]: sign+encrypt failed: public key not found I tried to find out how mailcrypt determines the path to gpg, and I found something interesting in /usr/share/emacs/site-lisp/mailcrypt/ "mc-gpg.el" contains this line: (defvar mc-gpg-path "gpg" "*The GPG executable.") And I find some references to the mc-gpg-path variable, but I'm not able to determine where or when it actually sets the path-variable. (I'm not very strong in lisp.) -- Filip