gnupg won't compile on Mac OS X

Gordon Worley
Sat, 6 Jan 2001 13:08:33 -0500

On Friday, January 5, 2001, at 06:29 AM, Werner Koch wrote:

> > An empty Makefile, if I interpret your description correctly, would IMHO
> > indicate problems with sed. autoconf is quite demanding here.
> What about case sensitivity of filenames? I remeber that I ran
> configure on some beta Mac OS X many month okay and we could compile
> most things.
Case sensitivity is not a problem, since I'm using UFS, which is a work alike fs of that used by the BSDs. I did this on purpose, since I knew that sometimes there is only a difference in case in file names in Unix software. HFS+, the old but still good fs of the Mac is just case preserving, but 'file' and 'File' can't reside in the same directory. Actually, most software compiles well, but both gnupg and bash had problems like this (fortunately, someone else figured out bash and put up OS X binaries for the rest of us). As a test, I tried running make with rather than the blank Makefile. This mostly worked, but on line 182 it comes back with: localhost% make -f *** missing separator. Stop. I should also note that it is just mainly GNU software that won't compile, so if there is something related to all GNU software's make process, maybe this is the problem. There must be some way around it, though, since Apple included plenty of GNU tools for use with the command line. Oh, one more thing. When running the previously mentioned logging of what ./configure does, I noticed this line related to sed: creating Makefile sed: 46: conftest.s1: unescaped newline inside substitute pattern creating intl/Makefile sed: 46: conftest.s1: unescaped newline inside substitute pattern creating po/ sed: 46: conftest.s1: unescaped newline inside substitute pattern etc., etc., etc. and this next line popped up a lot, though with different numbers at the end: checking host system type... ./configure: 5: bad file descriptor [742] Not being a make or sed master, I'm not entirely sure if they are relevant, but they looked like something that might matter. -- Archive is at - Unsubscribe by sending mail with a subject of "unsubscribe" to