Can't import secret keys

Melissa Melissa <>
Mon Jun 11 08:30:01 2001

Hash: SHA1

On Sunday, June 10, 2001, at 10:51:41 PM PDT, Chris wrote:

C> I'm using GnuPG 1.0.6 and PGP 6.5.8. I was able to import my public key
C> ring, but when I try to import my secret key ring I get the following
C> message: If not failed because of invalid Key-data.

C> I've tried importing the keyring itself and I've also tried exporting
C> the secret PGP key to an .asc file and trying to import that with
C> GnuPG. Same results.

Hello Chris,

I'm pretty new to using GnuPG as well. I use GnuPG 1.0.6 with GnuPG shell
v1.77. My PGP is Personal Security 7.0.3. Here's what I do when I want to
import secret keys from PGPkeys...

In PGPkeys, I Export the key(s) into "C:\gnupg" (putting a check mark in
"include private key(s)" before I export.

Then, I open a DOS box, and type the following:

cd C:\gnupg   <then press "enter">

gpg --import --allow-secret-key-import c:\gnupg\[filename].asc  <"enter">

This seems to work for me.  I hope it helps.

- --
PGP public keys:

Version: GnuPG v1.0.6 (MingW32) - GnuPGshell v1.77
Comment: I'm out of my mind, but feel free to leave a message.