GnuPG + Java

Jaya Christina
Mon Apr 29 14:09:01 2002

Hi *,

The following code is giving an error
        usage: gpg [options] [filename]

        when the -r is jaya christina in double quotes.

When I give same in single quotes also I get the same error.Same error for
without quotes.Any idea anybody??

If the -r is a single name in double or single quotes like 'jaya' the error
is : A recepient with name "jaya" is available.
        gpg: 'Kalibra'--armor: skipped: public key not found
        gpg: input.txt: encryption failed: public key not found

public class GnuPGTest{
 public static void main(String[] arg){
      Process p;
               String exec = "gpg -r Kalibra On
Web --armor --yes --batch --output output.gpg --encrypt input.txt"  ;
               p = Runtime.getRuntime().exec(exec);
               InputStream is = p.getErrorStream();
               String stream = "";
                    stream += (char);
               System.out.println(stream );
              }catch(Exception io){
                   System.out.println("Error creating process. IOException
encrypt" + io);

Jaya Christina