gnupg on FlashDisk with autofs (o.t.?)

Per Tunedal
Wed Dec 4 14:55:01 2002

At 19:18 2002-10-02 -0400, you wrote:
 >On Wed, Oct 02, 2002 at 12:08:15PM +0200, Thomas Liesner wrote:
 >> Hi,
 >> well, i actually resigned... There is no solution for it.
 >> The problem is the filesystem. Those flash-disks come with a vfat
 >> filesystem out of their box. Vfat does not know anything about
 >> users/permissions etc. (hence no chmod/chown etc.). The only solution is
 >> to mount it with umask 777 which is not really an option ;) Changing
 >> it's filesystem to to something like ext2nd is not working with my
 >> MacOS-X box and ufs is not working with my MacOS-9 box... And now think
 >> of ntfs...
 >> Okay, i think i stick to vfat and keep my hands securly on the disk...
 >> Too bad.
 >There is a solution.  The problem is in locking, so if you use
 >--lock-never then GnuPG will not try and lock the keyrings.  However,
 >you will need to make very sure you never run two copies of GnuPG at
 >the same time :)
 >One good way to do it is to keep the pubring online as it is the one
 >people generally need to write to when importing new keys, and only
 >keeping the secring on the flash disk.  No locking issues in that
 >system unless you want to add a new secret key.
I have got several USB-devices. One, a Pen Drive, is formatted like one 
1.44 MB bootable virtual USB floppy drive and one larger USB-drive. I 
suppose the larger part can be formatted differently from the virtual 
floppy. Will that help?

I haven't tried to install some UNIX on it yet. Unfortunately that would 
not make it possible to use WinPT. I suppose the GPA might be useful. Has 
anybody tried something similar?

Per Tunedal