IDEA module & HP-UX

Will Day
Wed Jun 12 03:26:02 2002

Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable

A short time ago, at a computer terminal far, far away, David Ellement wrot=
>I tried compiling idea.c on HP-UX with gcc.  While it compiled
>without errors and gpg --version showed IDEA as a cipher, I got
>the error message:
>    gpg: fatal: idea encryption (0) failed
>when I tried to edit my old RSA key.  Browsing the list archive, I
>found an old message:
>which seems to suggest there was a problem with the way the module
>was compiled.  Has anyone compiled idea.c on HP-UX and got a working

(old message..)

I had this problem, as I recall, under solaris when first installing gnupg;
the only way it worked for me was to use gcc rather than Sun's cc
(SUNWspro). =20

In the process of upgrading gnupg, I've found that the cause appears to be
that BIG_ENDIAN_HOST isn't getting properly defined at the top of idea.c.
More specifically, SUNWspro defines "__sparc" but does not define
"__sparc__", so the #if defined() wasn't evaluating true.

I would suggest checking the builtin defines of your compiler, and make
sure they're covered in the #ifdef.  I don't know if this will help in your
case, but it's worth a shot.

Will Day                  Those who would give up essential Liberty, to=20               purchase a little temporary Safety, deserve neith=
UNIX System Programmer    Liberty nor Safety.
Atlanta, GA                 - Benjamin Franklin, Penn. Assembly, Nov. 11, 1=

Content-Type: application/pgp-signature

Version: GnuPG v1.0.7 (Solaris)