Problem importing S/MIME certificates into GPGSM

Klavs Klavsen
Tue Apr 8 11:42:01 2003

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

Dear gnupg-users,

I'm not subscribed to the list (tried to send email to gnupg-users-subscrib=
e - but that didn't work, I have yet to find info on how to subscribe (I'm =
probably just blind).

I found a howto on the gpa-devel list:

describing howto use gpgsm.

The reason I wanted to try it - is that we in Denmark have gotten a digital=
 certifikate solution that is pkcs12 certifikates.
I have backed up my certificate from Mozilla to a pkcs12 file and then when=
 I try to invoke it I get a weird response.

when I envoke:

gpgsm --call-protect-tool  --p12-import --store certkey.p12

I get this output:
gpg-protect-tool: gpg-agent is not available in this session
gpg-protect-tool: error while asking for the passphrase

I tried starting the gpg-agent both as server and as deamon.

I've searched google and whatever I could find without finding an answer

Also - once this is working, I'm going to try and see if I can make
gpgsm work with evolution-1.2.3. If you have hints, please tell me.

Klavs Klavsen, GSEC

Open Source Server, Security and Network Consulting -
Phone: +45 3284 4372 Mobile: +45 2342 4372
PGP: 7E063C62/2873 188C 968E 600D D8F8  B8DA 3D3A 0B79 7E06 3C62

"Open Source Software - Sometimes you get more than you paid for."
Klavs Klavsen, GSEC - -

Working with Unix is like wrestling a worthy opponent.=20
Working with windows is like attacking a small whining child=20
who is carrying a .38.			=09

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.2.1 (GNU/Linux)