OT? rpm --checksig problem

Dick Gevers dvgevers at xs4all.nl
Mon Dec 1 08:53:25 CET 2003

Hash: SHA1

On Sat, 29 Nov 2003 19:35:38 -0700, engage <engage at n0sq.net> wrote about OT?
rpm --checksig problem:

>Even though the public keys are on the keyring, running rpm --checksig on 
>packages tell me that the key is missing. I tried downloading the packages 
>from a different mirror but get the same problem. I even tried rpm --import
><pubkey> but that didn't help either. This began after a fresh install of 
>Mandrake 9.2 (was running 9.0). GnuPG 1.2.3-3.1.92mdk.

If I am not mistaken GnuPG isn`t even needed for the rpm --checksig

There are a few things you might want to do, if you haven`t done so already:

Update the Mandrake rpm* packages, which have been
published since 9.2 was distributed. 

Under Mandrake Control Center the keys can be managed via `Software Manager`
- - --> `Software Media Manager` --> Manage keys...

Apparently the required key not only needs to be on the rpm keyring but also
has to be associated with the source it is supposed to verify. If I run 
`rpm -K foo.rpm` it checks okay, but if it is not associated in Software
Media Manager RpmDrake will not recognize the key verifying it.

Besides, I don`t have an /etc/RPM-KEYS, Mandrake 9.2 seems to put them
elsewhere. Below /var/lib/rpm if I am not mistaken.

=Dick Gevers=
Version: GnuPG v1.2.3 (GNU/Linux)
Comment: Encryption is an envelope - the contents are private.


More information about the Gnupg-users mailing list