rpm --checksig problem

engage engage at n0sq.net
Mon Dec 1 18:25:42 CET 2003

On Monday 01 December 2003 01:53 am, Dick Gevers wrote:
>On Sat, 29 Nov 2003 19:35:38 -0700, engage <engage at n0sq.net> wrote about OT?
>rpm --checksig problem:
>>Even though the public keys are on the keyring, running rpm --checksig on
>>packages tell me that the key is missing. I tried downloading the packages
>>from a different mirror but get the same problem. I even tried rpm --import
>><pubkey> but that didn't help either. This began after a fresh install of
>>Mandrake 9.2 (was running 9.0). GnuPG 1.2.3-3.1.92mdk.
>If I am not mistaken GnuPG isn`t even needed for the rpm --checksig
No, but the public keys are required.
>There are a few things you might want to do, if you haven`t done so already:
>Update the Mandrake rpm* packages, which have been
>published since 9.2 was distributed.

I won't do that until I can verify the signatures on the packages.

>Under Mandrake Control Center the keys can be managed via `Software Manager`
>- --> `Software Media Manager` --> Manage keys...

I tried that plus rpm --import. I still get the error message that the keys 
are missing.

>Apparently the required key not only needs to be on the rpm keyring but also
>has to be associated with the source it is supposed to verify. If I run
>`rpm -K foo.rpm` it checks okay, but if it is not associated in Software
>Media Manager RpmDrake will not recognize the key verifying it.

I've never had this problem in earlier distros. Why is 9.2 different?

>Besides, I don`t have an /etc/RPM-KEYS, Mandrake 9.2 seems to put them
>elsewhere. Below /var/lib/rpm if I am not mistaken.
>=Dick Gevers=
>Gnupg-users mailing list
>Gnupg-users at gnupg.org

More information about the Gnupg-users mailing list