gpg: no handler for keyserver scheme "ldap"

Todd Todd <>
Thu Feb 6 01:44:02 2003

Hash: SHA1

Marcus Eger wrote:
> I've got a debian woody system kernel 2.4.19 and  gpg (GnuPG) 1.2.1 (binary 
> standard debian installation). Why doesn't  the following work? 
> gpg --keyserver ldap:// --search-keys "<some person>"
> gpg: unable to execute program "gpgkeys_ldap": No such file or directory
> gpg: no handler for keyserver scheme "ldap"
> The file gpgkeys_ldap definitely exists: /usr/lib/gnupg/gpgkeys_ldap
> and even copying into the exec-path does not help.

I had this same error when I built 1.2.1 on a redhat box, using the same
specfile I had used in the past.  The problem in my case was that
keyservers/Makefile added gnupg onto the end of the whatever was passed in
as libexecdir.  So when the rpm specfile passed in /usr/lib/gnupg as
libexecdir, the keyserver makefile was making that /usr/lib/gnupg/gnupg.  I
found this out by running strings on the gpg binary.

Try this as a test, cd to /usr/lib/gnupg and symlink gnugp to . and see if
that helps.  If so, you've got the same problem.

I tried asking about this on the redhat phoebe list (since the phoebe rpm
still uses the same specfile as 1.0.7 and is therefore likely to fail on
ldap lookups) but I didn't get any replies.  I've been meaning to ask here
about this but hadn't gotten around to it (until now :).

I noticed in looking at the makefiles that there is a GNUPG_LIBEXECDIR as
well as the normal libexecdir defined.  In all the makefiles except in
keyservers, libexecdir is set to what the user passed in and
GNUPG_LIBEXECDIR is $libexecdir/gnupg.  Is it intentional that the
keyservers makefile is different?

- -- 
Todd              OpenPGP -> KeyID: 0xD654075A | URL:
Government of man by man in every form is oppression.
    -- Pierre Joseph

Version: GnuPG v1.2.1 (GNU/Linux)
Comment: When crypto is outlawed bayl bhgynjf jvyy unir cevinpl.