gnupg 1.2.1 IDEA support

Goober Rama
Wed Feb 12 22:47:02 2003

If anyone can help out with this, I would greatly appreciate it.  I've read 
through many of the archives and have tried I think all of the recommended 
solutions to no avail.

We're attempting to use gpg on AIX 5.1 and have the need to import some old 
pgp 2.x keys. So, I've tried using 'load-extension idea' in my options file 
after compiling the idea.c module and copying it to /usr/local/lib/gnupg.  
The output of 'gpg --version' always returns the 'idea encryption (0) 
failed' error.  I have tried this with the pre-compiled binary available 
from (both 1.2.1 and 1.0.7) and 
compiling 1.2.1 and 1.0.7 from source.  I've tried compiling both with IBM's 
C for AIX version 5 and the gcc (with the necessary CFLAGS statement as 
outlined in the README).  I have tried using both IBM's packaged gcc 
(version 2.9) and version 3.2.1 available from UCLA.

Summary of software versions and steps taken:

AIX 5.1 - 5100-03
C for AIX 5
gcc 2.9 (IBM's package)
gcc 3.2.1 (UCLA)
gpg 1.2.1 - compiled from source
gpg 1.2.1 - binary from Bull Freeware
gpg 1.0.7 - compiled from source
gpg 1.0.7 - binary from Bull Freeware
idea.c.gz - from

configure: CFLAGS="-g -O2 -mcpu=powerpc" ./configure --disable-nls 
--with-included-gettext --enable-static-rnd=egd --disable-asm 
--disable-dev-random --with-egd-socket=/dev/egd

I've tried compiling idea.c in with everything else by having it in the 
<souce-dir>/cipher directory and compiling it separately with

gcc -Wall -O2 -shared -fPIC -o idea idea.c

and using the 'load-extension' option.  Everything still ends up with 'idea 
encryption (0) failed'.

If anyone can shed some light on this get help me get over this hurdle, that 
would be great.


Protect your PC - get VirusScan Online