Problems using --keyring

Carl B. Constantine
Wed Jan 15 16:32:01 2003

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I'm trying to host a GPG Signing party for members of our LUG (VLUG -- as described in this excelent article: However, the
--keyring option in GnuPG doesn't seem to be working.

I exported a bunch of keys to a separate file from my current public
keyring. if I run gpg --fingerprint --keyring newkeyfile.gpg, I get
fingerprints from my regular public keyring not the new file. It doesn't
seem to matter if the gpg file is in armor ascii or binary format.

Also, commands like this: gpg --import keyfile.asc --keyfile newfile.gpg
do not work either, ie: it won't create ~/.gnupg/newfile.gpg or even
~/newfile.gpg, it just imports into my regular public keyring.

I've tried this using GnuPG 1.2.1 on Debian 3.0 and RedHat 8.0 to the
same effect.

Is there a setting I'm missing? How can I manage multple public
keyrings? I don't see any docs on this other than the information about
--keyring in the man pages.

Thanks in advance.

 .''`.      Carl B. Constantine
: :' :
`. `'    GnuPG: 135F FC30 7A02 B0EB 61DB  34E3 3AF1 DC6C 9F7A 3FF8
  `-  Debian GNU/Linux -- The power of freedom

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (GNU/Linux)