Error during make - i386ld fatal:Symbol referencing error

John Hill
Wed Jan 15 22:41:03 2003

-----Original Message-----
From: []On
Behalf Of David Shaw
Sent: Wednesday, January 15, 2003 3:09 PM
Subject: Re: Error during make - i386ld fatal:Symbol referencing error

On Wed, Jan 15, 2003 at 02:50:16PM -0500, John Hill wrote:

> It looks like my first reply didn't make it.  I think it may have went
> directly to David.  I am new to most of this so please bear with me.  How
> would I check the libraries to find where these functions are defines.  I
> tried looking at the .a files but those look like they are binary files.
> also tried to compile from the command line adding the -lresolv and both
> the -lresolv and -lsnl options and I get the same message.

Use the program "nm" on the .a files.  You are looking for the name of
the missing symbols plus a capital letter "T".  If you see that, then
the symbols are defined in that .a file.  I'm assuming your nm is like
mine here.  I'm not familiar with the SCO nm.

Anyone out there with a SCO box have any other ideas?


   David Shaw  |  |  WWW
   "There are two major products that come out of Berkeley: LSD and UNIX.
      We don't believe this to be a coincidence." - Jeremy S. Anderson

Gnupg-users mailing list

Thanks for all of the help.  I found another reference to inet_addr in the
libresolv.a library.  I change the Makefile in the tools and g10 directories
to add /usr/lib/libresolv.a to the needed_libs variable and everything
compiled fine.  My first question, is this the best way to correct this or
should I do something else.

Now when I run gpg --gen-key the application locks up after I enter my name,
email, and comment fields (I am leaving email and comment blank) and I
select O for okay.  I never get asked to enter a passphrase.

Thanks again.

John Hill