Error during make - i386ld fatal:Symbol referencing error

David Shaw
Wed Jan 15 21:08:03 2003

On Wed, Jan 15, 2003 at 02:50:16PM -0500, John Hill wrote:

> It looks like my first reply didn't make it.  I think it may have went
> directly to David.  I am new to most of this so please bear with me.  How
> would I check the libraries to find where these functions are defines.  I
> tried looking at the .a files but those look like they are binary files.  I
> also tried to compile from the command line adding the -lresolv and both
> the -lresolv and -lsnl options and I get the same message.

Use the program "nm" on the .a files.  You are looking for the name of
the missing symbols plus a capital letter "T".  If you see that, then
the symbols are defined in that .a file.  I'm assuming your nm is like
mine here.  I'm not familiar with the SCO nm.

Anyone out there with a SCO box have any other ideas?


   David Shaw  |  |  WWW
   "There are two major products that come out of Berkeley: LSD and UNIX.
      We don't believe this to be a coincidence." - Jeremy S. Anderson