Error during make - i386ld fatal:Symbol referencing error

John Hill
Wed Jan 15 20:52:02 2003

-----Original Message-----
From: []On
Behalf Of David Shaw
Sent: Wednesday, January 15, 2003 11:11 AM
Subject: Re: Error during make - i386ld fatal:Symbol referencing error

On Wed, Jan 15, 2003 at 10:36:35AM -0500, John Hill wrote:
> Thanks David.
> I issued command
>      cc -g -o bftest bftest.o ../cipher/libcipher.a ../mpi/libmpi.a
> ../util/libutil.a \
>      -lsocket -lnsl ../intl/libintl.a
> on the command line from the tools subdirectory and received the same
> message, which I have included again.

Ah, I love the game of "guess the dependency"!

Can you take a look in your /usr/lib directory and see which library
defines the missing symbols?

You might also try -lresolv (which in turn may require -lnsl - try


   David Shaw  |  |  WWW
   "There are two major products that come out of Berkeley: LSD and UNIX.
      We don't believe this to be a coincidence." - Jeremy S. Anderson

Gnupg-users mailing list

It looks like my first reply didn't make it.  I think it may have went
directly to David.  I am new to most of this so please bear with me.  How
would I check the libraries to find where these functions are defines.  I
tried looking at the .a files but those look like they are binary files.  I
also tried to compile from the command line adding the -lresolv and both
the -lresolv and -lsnl options and I get the same message.

Thanks for all of your help.

John Hill