Problems with a key or passphrase I was given

Stephen Montgomery-Smith
Sat Jun 7 17:23:02 2003

I am in charge of maintaining a script that creates messages for a mailing list, 
and these messages are supposed to be signed using gnupg.  This is all stuff I 
was given, in particular, I did not create the keys.

The set up I have seems to work if I use a version 1.0.4, but not for any later 
version.  I get error messages, and I have no idea what they mean.  I am 
guessing that something is corrupted, and perhaps version 1.0.4 did not properly 
handle it.  If it is corrupted, I would like to know if it is possible to fix it 
without changing the public key.

This is (in effect) how the script uses gnupg:

cat passphrase message | gpg --passphrase-fd 0 --force-v3-sigs
--clearsign--no-secmem-warning --batch

and the response is

gpg: [don't know]: invalid packet (ctb=73)
gpg: keydb_search failed: invalid packet
gpg: key C380B4D8: secret key without public key - skipped
gpg: no default secret key: secret key not available
gpg: [stdin]: clearsign failed: secret key not available

If I run version 1.0.4 I still get error messages:

Reading passphrase from file descriptor 0

You need a passphrase to unlock the secret key for
user: "gpg: [don't know]: invalid packet (ctb=73) near 1
gpg: read_keyblock: read error: invalid packet
gpg: enum_keyblocks failed: invalid keyring
[User id not found]"

but gnupg still produces a signed message as its output.

Stephen Montgomery-Smith