OT? rpm --checksig problem

David R. Bergstein dbergstein at comcast.net
Sat Nov 29 23:00:39 CET 2003

On Saturday 29 November 2003 09:35 pm, engage wrote:
> Even though the public keys are on the keyring, running rpm --checksig on
> packages tell me that the key is missing. I tried downloading the packages
> from a different mirror but get the same problem. I even tried rpm --import
> <pubkey> but that didn't help either. This began after a fresh install of
> Mandrake 9.2 (was running 9.0). GnuPG 1.2.3-3.1.92mdk.

You may need to see if the path for the public keyring that RPM uses in MDK 
9.2 is different than 9.0.   On my MDK 9.0 systems, the file that controls 
this behaviour is /etc/rpm/macros (see below for sample).

# /etc/rpm/macros
%_signature     gpg
%_gpg_path      /etc/rpm-keys

David R. Bergstein
Systems Engineer and Blues Musician - 
Heart of Blue - bookings on-line at http://www.heartofblue.com
OpenPGP Public Key 0xE1F138CA - For info see http://www.gnupg.org
Key fingerprint = C86E CA2A 4171 AC73 91D7  3DCE 8832 D764 E1F1 38CA

Our business in life is not to succeed but to continue to fail in high 
		-- Robert Louis Stevenson

More information about the Gnupg-users mailing list