OT? rpm --checksig problem

engage engage at n0sq.net
Sun Nov 30 11:10:20 CET 2003

On Saturday 29 November 2003 09:00 pm, David R. Bergstein wrote:
>On Saturday 29 November 2003 09:35 pm, engage wrote:
>> Even though the public keys are on the keyring, running rpm --checksig on
>> packages tell me that the key is missing. I tried downloading the packages
>> from a different mirror but get the same problem. I even tried rpm
>> --import <pubkey> but that didn't help either. This began after a fresh
>> install of Mandrake 9.2 (was running 9.0). GnuPG 1.2.3-3.1.92mdk.
>You may need to see if the path for the public keyring that RPM uses in MDK
>9.2 is different than 9.0.   On my MDK 9.0 systems, the file that controls
>this behaviour is /etc/rpm/macros (see below for sample).
># /etc/rpm/macros
>%_signature     gpg
>%_gpg_path      /etc/rpm-keys

I added the %signature line. The /etc/rpm-keys doesn't exist anywhere on my 

Adding the one line didn't help. As for /etc/rpm-keys, not sure of what to do 
about that. I don't even know if that'll help even if it is created.

More information about the Gnupg-users mailing list