Decryption failed error

Suhas Tembe sgtembe at
Wed Dec 8 17:49:07 CET 2004

Hello Everyone,

We sent our RSA 2048-bit public key to a customer (key id: CBD20614) which 
they were able to import into their key-ring. They sent us their RSA 
2048-bit public key (Key id: A1C09977), which I have imported into the 
key-ring & given it the ultimate trust and have also signed it. The customer 
encrypted a test file using our public key & signed it using their key.

When I try to decrypt the file at our end, I get the following error:

>gpg: encrypted with ELG-E key, ID 6A4285DA
>gpg: decryption failed: secret key not available

I tried ./gpg --list-keys & I see only the CBD20614 & A1C09977 keys. I also 
./gpg --list-secret-keys, but I only see the CBD20614 key. I don't see the 
6A4285DA key id at all.

I also tried ./gpg --verify & I get the following message:

>gpg: verify signatures failed: unexpected data

It seems to me that the customer used the wrong key to encrypt the file & 
send it to us. Am I correct or am I missing something?

Can someone give me any suggestions as to why this could be happening?

Thanks for any help.

More information about the Gnupg-users mailing list