Decryption failed error

David Shaw dshaw at
Fri Dec 10 02:39:32 CET 2004

On Wed, Dec 08, 2004 at 11:49:07AM -0500, Suhas Tembe wrote:
> Hello Everyone,
> We sent our RSA 2048-bit public key to a customer (key id: CBD20614) which 
> they were able to import into their key-ring. They sent us their RSA 
> 2048-bit public key (Key id: A1C09977), which I have imported into the 
> key-ring & given it the ultimate trust and have also signed it. The 
> customer encrypted a test file using our public key & signed it using their 
> key.
> When I try to decrypt the file at our end, I get the following error:
> >gpg: encrypted with ELG-E key, ID 6A4285DA
> >gpg: decryption failed: secret key not available
> I tried ./gpg --list-keys & I see only the CBD20614 & A1C09977 keys. I also 
> tried
> ./gpg --list-secret-keys, but I only see the CBD20614 key. I don't see the 
> 6A4285DA key id at all.
> I also tried ./gpg --verify & I get the following message:
> >gpg: verify signatures failed: unexpected data
> It seems to me that the customer used the wrong key to encrypt the file & 
> send it to us. Am I correct or am I missing something?

What happens when you say 'gpg --list-keys 6A4285DA' ?  If nothing,
then it does seem like your customer encrypted to the wrong key.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 251 bytes
Desc: not available
Url : /pipermail/attachments/20041209/5e59e04a/attachment-0001.bin

More information about the Gnupg-users mailing list