UTF8 passphrase problem (I think)

Tom Hardy rhardy at visi.com
Sat Jul 24 00:43:17 CEST 2004

Atom 'Smasher' wrote:

> Hash: SHA256
> On Fri, 23 Jul 2004, Tom Hardy wrote:
>> Interesting thing here, when I tried pasting and editing your example
>> I got stuff like this:
>> tom at jeeves:~>
>> gpgÿÿ--exportÿÿ{07cf11c6}ÿÿ|ÿÿgpgÿÿ--homeÿÿ~/gpg-junkÿÿ--import bash:
>> gpgÿÿ--exportÿÿ{07cf11c6}ÿÿ: command not found bash:
>> ÿÿgpgÿÿ--homeÿÿ~/gpg-junkÿÿ--import: No such file or directory
>> But when I typed it all directly, it worked.  Shows, I guess, that
>> character encoding can be non-obvious.  

Ulp!  Well it was non-obvious when I sent it off, and when it came back
to me too.  0xA0, or no-break space in 8859-1 on my news spool, and
which ain't even supposed be possible under UTF-8--it indicates a
continuation byte.

Mutt shows it as "??", two bytes.  I can't wait to see what Mutt says
you said.  (I get the digest.)

You quoted me with 0xFFFF, another impossible UTF encoding, or a pair of
"y"'s with diaeresis under 8859-1, on my news spool.


> and you do have spaces in your passphrase, right?

Yup.  The matter is still not explained, but the next step is obvious...
> i would try editing the keys on a different machine... or, maybe load
> up a knoppix-like OS from CD and try editing your keys on that.

Well, I can still boot into Win98--I guess I need to dig up a copy of
PGP or GPG for it.  And then to send some feedback to Suse, depending
on how things go.

Tom Hardy  <*>  rhardy at visi.com  <*>  http://www.visi.com/~rhardy
  Just don't create a file called -rf. --Larry Wall

More information about the Gnupg-users mailing list