Can't locate public key or pubring.gpg - followup

InHisGrip servie_platon at
Fri Jul 30 13:03:20 CEST 2004

Hi Atom,

Thanks for the reply.

Initially, I intend to use gnupg to encrypt and sign
or maybe just sign my emails because I wanted to make
sure that the email gets received by the intended
party as really coming from me.

But I have a lot of questions in mind since I am new
to gnupg.

For instance,

1. Can I make my keys from /home/servie logged in
root? Or shall I just logout of root and login using
ordinary account and make myself another set of keys? 

2. Can I just mv ~/.gnupg to /home/servie? And log in
as user servie and be able to encrypt and sign.

3. Initially, I'd like to sign and encrypt attached
file from my linux box and scp or ssh the file from
this box to my windows machine in my small home
network so that I could send an email with this

Is there a better way to do this? I find that all
gnupg experts who has emails replied to this user
group has their email signed.

I tried a windows frontend WinPT but it is hard to use
especially with clipboard.  Is there a fast way to
sign or encrypt emails from windows? How do you
customize your email so that all outgoing emails get a
begin pgp signed message and end with the gnupg users
list below? It's really cool and nice looking. My
account is yahoo.

And final question, any tips in sending encrypting
files across the internet using gnupg on top of scp or
ssh? I just need some ideas?

Thanks a lot! Special mention also to John who also
helped out.

--- Atom 'Smasher' <atom at> wrote:

> Hash: SHA256
> > I compiled successfully gnupg-1.2.5.tar.gz. I
> followed
> > the instructions on the gnupg handbook from
> generating
> > a new key pair to generating a revocation
> certificate
> > which all worked fine.
> >
> > However, when I went on to the section exchanging
> keys
> > and exporting public key I could not get any
> > improvement.
> >
> > If I do the command: # gpg --list-keys, I get only
> pub
> > and sub. I don't see anything in the output:
> > pubring.gpg.
> >
> > Did I do something wrong during the compile though
> I
> > throught everything was fine? I could not find the
> > public key so that I could export it or copy it to
> my
> > windows machine.
> >
> > Any tips would be highly appreciated. Thanks in
> > advance.
> ==========================
> i'm assuming that you have a linux or unix type
> machine...
> in the above command, the prompt is a pound sign.
> are you running this as 
> root? off topic, but it's usually best to avoid
> running things as root 
> unless you have to.
> anyway, what happens if you do:
>  	gpg --list-keys
> or:
>  	gpg -a --export
> reading between the lines, it seems that you might
> be confused about 
> exporting keys and listing keys... if you run the
> command above, it might 
> make more sense. if it doesn't make more sense then
> let us know what error 
> messages you get.
>   	...atom
>   _________________________________________
>   PGP key -
>   762A 3B98 A3C3 96C9 C6B7 582A B88D 52E4 D9F5 7808
>   -------------------------------------------------
>  	"If someone created a database of all primes,
> won't he be
>  	 able to use that database to break public-key
> algorithms?
>  	 Yes, but he can't do it. If you could store one
> gigabyte
>  	 of information on a drive weighing one gram, then
> a list
>  	 of just the 512-bit primes would weigh so much
> that it
>  	 would exceed the Chandrasekhar limit and collapse
> into a
>  	 black hole... so you couldn't retrieve the data
> anyway"
>  		-- Bruce Schneier, Applied Cryptography
> Version: GnuPG v1.3.6 (FreeBSD)
> Comment: What is this gibberish?
> Comment:
> =Qp+y
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages! 

More information about the Gnupg-users mailing list